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Introduction 
 

The SBE 45 MicroTSG Thermosalinograph is externally powered, high 
accuracy, conductivity and temperature recorders, designed for 
shipboard determination of sea surface (pumped-water) conductivity 
and temperature.  
 
The SEAS TSG (Thermosalinograph) Data Recorder is a real time data 
acquisition, data processing, and data recording application that operates 
on vessels where there is a SBE 45 MicroTSG Thermosalinograph unit 
installed collecting TSG data. It receives continuously the measured sea 
surface temperature and conductivity data over the serial port RS-232. 

SEAS Transceiver Interface application or a NMEA device gives the ship’s position. 
Every received TSG data is archived in a file that will be zipped at 12:00 am every day, 
and will be copied to the Iridium’s queue for the transmission via satellite. 
 
The user can sets the collection sampling interval in seconds between samples that the 
SEAS TSG Data Recorder takes and archives, and the transmission sampling interval in 
seconds between samples that the SEAS TSG Data Recorder takes and put ready to 
transmit. 
 
It was developed in the Integrated Development Environment (IDE) from Microsoft 
Visual Studio C++ 2008 Standard Edition under Windows 7. 
 
Contact Information 
 
Caridad Ibis Gonzalez 
Software Developer 
UM/RSMAS/CIMAS and NOAA/AOML/PhOD 
4301 Rickenbacker Causeway 
Miami, FL 33149 
Phone: (305) 361-4322 
Fax: (305) 361-4392 
E-mail: caridad.i.gonzalez@noaa.gov 
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How does it work? 
 
SBE 45 MicroTSG Thermosalinograph 
 
Hardware installation 
 

  
 
System communication 
 
The Interface Box merges GPS data and SBE 38 remote temperature data with SBE 45 
data. The data, in ASCII engineering units, is passed to the computer for storage and/or 
display. 
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Once the system is ready for deployment is important to paid attention to the serial port 
settings on the SEAS TSG Data Recorder side. The length of the cable and the baud rate 
are related, see hardware documentation for more information.  
 
Computer serial port setting: 
 

 SBE 45 MicroTSG 
Baud rate 9600 
Data bits 8 
Parity None 

Stop bits 1 
Flow Control None 

 
 
The time between each output scan is governed by the SBE 45 MicroTSG setup. The 
Interface Box outputs the most recent data from the SBE 38 remote temperature sensor 
and/or GPS device with each scan of SBE 45 data. The SEAS TSG Data Recorder set the 
sampling interval to 1 second as default.   
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User Interface 
 
The Graphic User Interface (GUI) is simple, and makes the application interfaces 
intuitive, learnable, and consistent. To do easier the work with the application, the 
controls, and assesses are grouped. 
 

 
 
Main screen 
 
Serial port setup group: Sets up the serial port communication. 
 

On: Starts or stops the read data task via serial port. 
 
Instrument group: Chooses the used TSG unit (SBE 45). 
 
Sampling interval group: Sets up the sampling interval. 
 

Collection: Sampling interval in seconds between samples that the SEAS TSG Data 
Recorder takes and archives. 
 
Transmission: Sampling interval in seconds between samples that the SEAS TSG 
Data Recorder takes and put ready to transmit. 

 
GPS data source group: Selects the source to read the GPS data. It could be the 
connected NMEA device to the Interface Box, the SEAS Transceiver Interface 
application, or another application running in a remote computer that transmits data 
across the wire.  
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Ship setup group: Shows the ship information, and displays the ship’s speed. 
 
Technician setup group: Name, Email and Phone show the TSG technician’s 
information, alternate Name, alternate Email and alternate Phone are for the alternate 
TSG technician. 
 
Parsed TSG data ready to archive list: Displays the incomming TSG and GPS data, 
this read from SEAS Transceiver Interface or from NMEA device. These collected data 
will be recorded into …\Archive\TsgDataRecorder\SrvArchv directory. 
 
Raw incomming TSG data list: Displays the read ASCII string received from the TSG 
unit. The information is giving in following format: 
 
t1= 22.3107, c1=-0.00027, s=  0.0000, sv=1489.235, t2= 22.4613[, lat= 25 44.07 N, lon= 
080 09.71 W, hms= 131234, dmy= 290410] 
 
Where 
t1 = SBE 45 temperature 
c1 = SBE 45 conductivity 
s  = salinity 
sv = sound velocity 
t2 = SBE 38 temperature 
lat = latitude from NMEA navigation device 
lon = longitude from NMEA navigation device 
hms = time  from NMEA navigation device 
dmy = date  from NMEA navigation device 
 
Each scan ends with a carriage return <CR> and line feed <LF>. 
 
Collection group: Sets up the collection process. The collection of data can be Delayed 
until a future time; this is when the collection of data will begin for transmission. This 
could be used if the user is in port and he know when will be leaving later. 
 
Transmission group: Sets the transmission process setup, and display information. 
 

Begin: Sets the time to begin the transmission process. 
 
No transmission when ship is stopped: Chooses if the collected data to transmit will 
be transmitted when the ship is stopped (speed less than or equal to 1 knot) or not. 
 
Satellite transmission is allowed: Starts or stops the task that copies the recorded 
data to the Iridium’s queue for the real transmission via satellite using the Iridium 
Mailer Service. 
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Interval: Sets the transmission lapse in which the data will be transmitted; it should 
be greater or equal 5 minutes, the time it takes to make the application initialization. 
 
Countdown: Displays the time remaining for the next transmission. 
 
Last: Shows the moment when the last transmission took place. 
 
Next: Displays the moment when the next transmission will take place. 

 
Button Save: Makes active the new application configuration, and saves any 
configuration change from serial port, TSG unit, ship or technician into 
TsgDataRecorder.ini file. 
 
Status bar: Provides status information from serial port communication, and application. 
 
Main Menu 
 
File > Maximize: This command is always disabled see system tray to know how to 
maximize the SEAS TSG Data Recorder application window. 
 

 
 
 
File > Minimize: Use this command to minimize the SEAS TSG Data Recorder 
application window. An icon will be display in the system tray. 
 

 
 
 
The notification area -commonly referred as the 
system tray for Microsoft- is the portion of the 
taskbar usually at the bottom right corner that 
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displays icons for easy access to system functions such as printer, modem, sound volume, 
battery status, and more. It is used to launch and monitor running applications. 
 
A single right click on the tray icon will 
bring up a menu while a double click 
will perform the default action 
(Minimize or Maximize the SEAS TSG 
Data Recorder application window).  
 
 
 
 
File > Exit: Use this command to exit the SEAS TSG Data Recorder application. 
 

 
 
 
Since the SEAS TSG Data Recorder needs to stay running all the time unless they are 
explicitly terminated it prompts the user for a password to exit the application. 
 

 
 
 
View > Status Bar: Use this command to show or hide the status bar. 
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This command displays and hides the status bar, which describes the action to be 
executed by the selected menu item, and keyboard latch state. A checkmark appears next 
to the menu item when the status bar is displayed. 
 
The status bar is displayed at the bottom of the SEAS TSG Data Recorder window. The 
left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus. This area similarly shows messages that describe the 
application’s status. 
 
The right areas of the status bar indicate which of the following keys are latched down: 
 
Indicator Description 
CAP  The Caps Lock key is latched down. 
NUM  The Num Lock key is latched down. 
SCRL  The Scroll Lock key is latched down. 
DATE  The system clock. 
 
Setup > Transmission queue directory: Use this command to select the transmission 
queue path. 
 

 
 
 
Using this command you can select the transmission queue 
directory, where SEAS TSG Data Recorder will post the files 
ready to transmit. A Browser for Folder dialog appears that 
allows the user to select a folder. 
 
When this dialog box comes up, it displays the Desktop folder 
as the parent and all the other folders can be located from it. To 
use it, the user can click one of the folders or drives and click 
OK. If the desired folder is not seen but is available, the user 
can expand the existing folders and drives, click the desired 
folder, and click OK. If the necessary folder is not available at 
all, the user should first create the desired folder outside the 
application. 
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Setup > Reading calibration coefficients: Use this command to select if the SEAS TSG 
Data Recorder read the calibration coefficients from the SBE 45 MicroTSG, and SBE 38 
remote temperature sensor, and updates the GUI automatically or the user has to type 
them. 
 

 
 
 
Setup > Remote GPS data source|Computer settings: Use this command to set the IP 
address, and the port number of the remote computer, which provides a GPRMC 
sentence. 
 
 

 
 
 
Once selected the window Remote computer settings appears. 
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Type the IP address of the remote computer, and insert the port number. Click OK. 
 
The TSG Data Recorder will connect with this remote computer via socket. 
 
Setup > Remote GPS data source > Initialize socket: Use this command to create, and 
to initiate the socket for connecting to server. 
 

 
 
 
Setup > Remote GPS data source > Connect socket: Use this command to connect the 
socket. 
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Setup > Remote GPS data source > Disconnect socket: Use this command to 
disconnect the socket. 
 

 
 
 
Setup > Remote GPS data source > Show message: Use this command to show the 
socket input. 
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Once selected the window Remote computer message appears. 
 

 
 
 
Setup > Remote command settings: Use this command to set the destination email 
address, which eventually get a diagnostic text message. 
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Once selected the window Remote command settings appears. 
 

 
 
 
Type the destination email address. Click OK. 
 
Tools > Zip and archive collected data: Use this command to put inside the zip folder 
all files generated with the collected data to archive. 
 

 
 
 
Tools > Transmit data: Use this command to pack the 
Xdata_CallSign_TSG_YYMMDDHHMMSS.txt file, and to put the zipped folder in to 
the Iridium Mailer Service’s queue. 
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Tools > Update calibration coefficients: This command reads, and updates the 
calibration coefficients. 
 

 
 
 
The calibration coefficients can be read automatically from SBE 45 MicroTSG, and SBE 
38 remote temperature sensor when the application starts or when the user clicks the 
option Automatic. The read calibration coefficients process takes a while. 
 
The calibration coefficients are very important metadata that have to be transmitted. If 
you use this command the dialog SEAS TSG Data Recorder – Calibration Coefficients 
comes up. If the Reading calibration coefficients selected option is Automatic, the 
dialog box shows the automatically read calibration coefficients of the instruments, and 
the user doesn’t have access to some edit fields. Otherwise, if the selected option is 
Manual the user has to type the coefficients. 
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TSG unit group: Shows the calibration coefficients read automatically from the 
instruments. Pipe length and Intake depth correspond to the TSG physical architecture. 
 

Intake depth represents how deep the intake of the TSG water into the ship is below 
sea level. 
 
Pipe length is the length of pipe from water to TSG unit. 
 
Fo is the frequency. 

 
Remote sensor group: Shows the calibration coefficients read automatically from the 
instruments. Intake depth corresponds to the TSG physical architecture. 
 

Intake depth represents how deep the intake of the TSG water into the ship is below 
sea level. 

 
Pipe length is the length of pipe from water to remote sensor. 
 

Button OK: Saves any metadata change into TsgDataRecorder.ini file. 
 
Button Cancel: Ignores any change. 
 
Tools > Auto baud rate detection: Use this command to change the baud rate in the 
SBE 45 MicroTSG and/or SBE 38 remote temperature sensor for compatibility with the 
Interface Box. This automatic detection is useful for establishing communication between 
the instruments. 
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Tools > Communication test > Interface Box: Use this command to test if the 
application is able to communicate with the Interface Box, and displays its configuration. 
 

 
 
 
If the communication is established a screen with the current Interface Box configuration 
will appear. 
 

 
 
 



  TSG Data Recorder User’s Guide 
________________________________________________________________________ 
 
 

NOAA/AOML Page 17 of 30 3/7/2016 

Tools > Communication test > SBE 45 MicroTSG: Use this command to test if the 
application is able to communicate with SBE 45 MicroTSG through Interface Box, and 
displays its configuration. 
 

 
 
 
If the communication is established a screen with the current SBE 45 MicroTSG  
configuration will appear. 
 

 
 
 
Tools > Communication test > SBE 38 remote temperature sensor: Use this 
command to test if the application is able to communicate with SBE 38 remote 
temperature sensor through Interface Box, and displays the configuration. 
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If the communication is established a screen with the current SBE 38 remote temperature 
sensor configuration will appear. 
 

 
 
 
Tools > Set instruments default config > Interface Box: Use this command to read 
from .INI file the Interface Box’s default configuration setup, and sets them 
appropriately. 
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Tools > Set instruments default config > SBE 45 MicroTSG: Use this command to 
read from .INI file the SBE 45 MicroTSG ‘s default setup, and sets them appropriately. 
 

 
 
 
Tools > Set instruments default config > SBE 38 remote temperature sensor: Use 
this command to read from .INI file the SBE 38 remote temperature sensor‘s default 
setup, and sets them appropriately. 
 

 
 
 
Tools > Open folder containing archived data: Use this command to display in 
Windows explorer the folder where the data are archived. 
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Help > Help topics: Use this command to display the opening screen of help.  From the 
opening screen, you can jump to step-by-step instructions for using SEAS TSG Data 
Recorder and various types of reference information. 
 

 
 

Help > About SEAS TSG Data Recorder: Use this command to display the copyright 
notice and version number of your copy of SEAS TSG Data Recorder. 

 
 
 
Info: This menu provides you links to documents that can help you work with SEAS 
TSG Data Recorder. 
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Auto baud rate detection 
 
To achieve effective communication between the instruments, the baud rate for 
communication between the Interface Box and the computer must be greater than the 
baud rate between the Interface Box and the SBE 45 MicroTSG, and the baud rate 
between the Interface Box and the SBE 38 remote temperature sensor. The Auto baud 
rate detection feature allows changing the baud rate in the SBE 45 MicroTSG and/or 
SBE 38 remote temperature sensor for compatibility with the Interface Box. 
 
By default AOML set follow configuration: 
 
Communicated instruments Baud rate 
Interface Box - Computer 9600 
Interface Box – SBE 45 4800 
Interface Box – SBE 38 4800 
Interface Box – NMEA navigation device 4800 

 
This automatic detection is useful for establishing communication between the 
instruments. Once the communication between the instruments has been established a 
report will be generated. 
 

 
 
 
Detection technique 
 
To determine the baud rate of the instruments a command will be sent, and the response 
will be examined. If it doesn't match with the expected response then the baud rate will 
be changed until we get an expected answer. 
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Communicated instruments Baud rate range 
Interface Box - Computer 4800, 9600 or 19200 
Interface Box – SBE 45 1200, 2400, 4800 or 9600 
Interface Box – SBE 38 1200, 2400, 4800 or 9600 
Interface Box – NMEA navigation device 4800 or 9600 

 
 
Exchange algorithm 
 
The exchange algorithm is to change the baud 
rate while the instrument is communicating 
through the Interface Box. The procedure is 
assuming that we want the computer to 
communicate with the Interface Box at 9600 
baud, and the other instruments with the 
Interface Box at 4800 baud.  
 

1. Establish communication with the 
Interface Box using the detection 
technique. 

 
2. With the Interface Box in Normal mode, send PCBaud=19200 to change the 

baud rate between the Interface Box and the computer to 19200. 
 

3. Set the computer serial port’s baud rate to 19200. 
 
4. Modify the SBE 45 MicroTSG baud rate: 

A. Send 45Baud=9600 to set the baud rate in the Interface Box for 
communication with the SBE 45 MicroTSG to 9600. 

B. Send Connect45 to communicate with the SBE 45 MicroTSG. 
C. Stop sampling by sending Stop (it may need to send the command several 

times). 
D. Send Baud=4800 to set the SBE 45 MicroTSG baud rate to 4800. 
E. Send @ to return to the Interface Box. 
F. Send 45Baud=4800 to set the baud rate in the Interface Box for 

communication with the SBE 45 MicroTSG to 4800. 
 
5. Modify the SBE 38 remote temperature sensor baud rate: 

A. Send 38Baud=9600 to set the baud rate in the Interface Box for 
communication with the SBE 38 remote temperature sensor to 9600. 

B. Send Connect38 to communicate with the SBE 38 remote temperature 
sensor. 

C. Stop sampling by sending Stop (it may need to send the command several 
times). 
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D. Send Baud=4800 to set the SBE 38 remote temperature sensor baud rate 
to 4800. 

E. Send @ to return to the Interface Box. 
F. Send 38Baud=4800 to set the baud rate in the Interface Box for 

communication with the SBE 38 remote temperature sensor to 4800. 
 

6. Send PCBaud=9600 to change the baud rate between the Interface Box and the 
computer to 9600. 

 
7. Set the computer serial port’s baud rate to 9600. The Interface Box is now 

communicating with the computer at 9600 baud. 
 
 
Setting instruments default setup 
 
The data output format depends on the instruments’ configuration. The command’s 
values will be loaded from the .INI file.  
 
Commands to setup the Interface Box’s parameters. 
 

Command Value Description 
Format 0 Standard format. 
PCBaud 9600 Baud rate for communication between Interface Box and computer. 
45Baud 4800 Baud rate for communication between Interface Box and SBE 45. 
38Baud 4800 Baud rate for communication between Interface Box and SBE 38. 
NMEABaud 4800 Baud rate for communication between Interface Box and NMEA unit. 
 
Commands to setup the SBE 45 MicroTSG’s parameters. 
 

Command Value Description 
Interval 1 Interval (seconds) between samples. 
OutputCond Y Output conductivity (S/m) with data. 
OutputSal Y Output salinity (psu) with data. 
OutptSV Y Output sound velocity (m/sec) with data. 
SVAlgorithm C Calculate sound velocity as Chen and Millero. 
AutoRun Y Start sampling automatically when power on. 
SingleSample N Sample at rate specified by Interval= until power removed. 
AutoOff N Do not automatically go to sleep. 
NCycles 4 A/D cycles to average per sample. 
Baud 4800 Baud rate communication between SBE 45 and Interface Box. 
OutputFormat 0 or 1 Other format is not compatible with the Interface Box. 
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Commands to setup the SBE 38 remote temperature sensor’s parameter. 
 

Command Value Description 
Interface 232 Communication using RS-232. 
Navg 2 Number of A/D cycles to average for each sample. 
AutoRun Y Start sampling automatically when power on. 
Format C C, ITS-90. 
Digits 4 Number if digits after decimal point. 
Baud 4800 Baud rate communication between SBE 38 and Interface Box. 
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Archiving data 
 
The NOAA National Oceanographic Data Center (NODC) preserves and disseminates 
ocean data, including TSG data, in their Ocean Archive System (OAS); it allows the 
oceanographic community to use these data for a long time. 
 
The generated TSG data files contain the meta-data at the top, and the TSG data bellow. 
 
The $AOML:001 section corresponds to the meta-data. 
 

Designator Parameter Unit 
WMOID Ship Call Sign  
SHIPN Ship name  
IMONO Ship IMO number  
TEC Technician name  
TECM Technician email address  
TECP Technician phone  
TECA Alternate technician name  
TECAM Alternate technician email address  
TECAP Alternate technician phone  
TSGMOD TSG unit model  
TSGSN TSG unit serial number  
IDP TSG unit intake depth meter 
ILEN Length of pipe from water to TSG unit meter 
DCAL TSG unit calibration date  
COTG TSG unit temperature coefficient A0  
COTH TSG unit temperature coefficient A1  
COTI TSG unit temperature coefficient A2  
COTJ TSG unit temperature coefficient A3  
COCG TSG unit conductivity coefficient G  
COCH TSG unit conductivity coefficient H  
COCI TSG unit conductivity coefficient I  
COCJ TSG unit conductivity coefficient J  
COCPR TSG unit conductivity coefficient Cpcor  
COCTR TSG unit conductivity coefficient Ctcor  
COCWB TSG unit conductivity coefficient Wbotc  
EXTMOD Remote sensor model  
EXTSN Remote sensor serial number  
EXTDCAL Remote sensor calibration date  
EXTTD Remote sensor intake depth meter 
EXTTL Remote sensor length of pipe meter 
COA0 Remote sensor temperature coefficient A0  
COA1 Remote sensor temperature coefficient A1  
COA2 Remote sensor temperature coefficient A2  
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COA3 Remote sensor temperature coefficient A3  
 
The $AOML:002 section corresponds to the TSG data. 
 
Designator Parameter Unit 
YMD PC date: Year Month Day UTC 
HMS PC time: Hour Minute Second UTC 
LAT GPS Latitude degree (+N, -S) 
LON GPS Longitude degree (+E, -W) 
INT TSG unit temperature* C, ITS-90 
SAL TSG unit salinity* PSU 
COND TSG unit conductivity* siemens/meter 
EXT Remote sensor temperature C, ITS-90 
 
* All samples are instantaneous. No averaging. 
 
TSG data is time and position stamped with time and position data from satellites and this 
is the data that is archived. This format is compatible with data coming from other TSG 
server on the NOAA ships, which do not use our application for TSG acquisition data. 
 
Data collection 
 
SEAS TSG Data Recorder application archives the collected TSG data in a text file in the 
…\Archive\TsgDataRecorder\SrvArchv directory. The data are recorded at the speed 
of the Collection-sampling interval field. 
 

 
 
The file name TEST_20120912155123_Sdata_TSG.txt stands for: 
 
TEST   = Ship call sign 
20120912155123 = generation time, format: YYYYMMDDHHMMSS 
Sdata   = fixed text to distinguish collected data  
TSG   = fixed text 
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The generated file will be zipped at 12:00 am every day, when the user selects Main 
Menu > Tools > Zip and archive collected data option or when the application exits. 
 

 
 
 
The zipped files are taken off the ship by a technician every few months or as scheduled. 
Its name has typically following format: CallSign_YYYYMMDDHHMMSS 
_Sdata_TSG.zip where: 
 
CallSign   = Ship call sign 
YYYYMMDDHHMMSS = generation time 
Sdata    = fixed text to distinguish collected data 
TSG    = fixed text 
 
The S_Log.txt file into the same directory contains information about the zipped archive 
files.  It is used to keep track of when zipped files are created and what was inside of it. 
 

 
 
Where 
 
Zipfolder = Zipfolder name, path included                                                                              
Date  = Date the zipfolder was created 
Filename = The name of archived file into zipfolder 
Size  = The length of the archived file, in bytes 
Date  = The last time the archived file was changed  
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Data transmission 
 
The ready collected data to be transmitted will be recorded into 
…\Archive\TsgDataRecorder\XmtArchv directory at the speed of the Transmission-
sampling interval field. 
 
These files have the same format as the collected data files; the data could be equal to the 
collected data or a sampling subset. For example the sampling of the data collected 
maybe is 10 seconds, and the sampling of the data ready to transmit maybe is 60 seconds. 
This feature allows reduce the transmission costs by reducing the size of the files to 
transmit. 
 

 
 
The file name TEST _20120912155123_Xdata_TSG .txt stands for: 
 
TEST   = Ship call sign 
20120912155123 = generation time, format: YYYYMMDDHHMMSS 
Xdata   = fixed text to distinguish transmitted data  
TSG   = fixed text 
 
The generated file to transmit TSG data will be zipped at the user selected time to zip and 
transmit data in Transmission interval fields, when the user selects Main Menu > Tools 
> Transmit data option or when the application exits. 
 

 
 
 
Its name has typically following format: 
CallSign_YYMMDDHHMMSS_Xdata_TSG.zip where: 
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CallSign   = Ship call sign 
YYYYMMDDHHMMSS = generation time 
Xdata   = fixed text to distinguish transmitted data  
TSG    = fixed text 
 
The X_Log.txt file into the same directory contains information about the zipped archive 
files.  It is used to keep track of when zipped files are created and what was inside of it. 
 

 
 
Where 
Zipfolder = Zipfolder name, path included                                                                              
Date  = date the zipfolder was created 
 
Filename = The name of archived file into zipfolder 
Size  = The length of the archived file, in bytes 
Date  = The last time the archived file was changed  
 
Transmission process 
 
The transmission process in SEAS TSG Data Recorder application is a pseudo 
transmission process. It consists to copy the 
CallSign_YYYYMMDDHHMMSS_Xdata_TSG.zip file from 
…\Archive\TsgDataRecorder\XmtArchv directory to the Iridium’s queue for the real 
transmission via satellite using the Iridium Mailer Service. When the remission is 
completed, it is logged in the transmission log file. 
 
The transmission log file Xmit_Log.txt contains information about when the file was 
sent to Iridium Mailer Service’s queue. This is written after the data is sent to Iridium’s 
queue, and is a safeguard to insure status of files sent to this directory. 
 

 
 
Where 
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Folder  = File sent to Iridium Mailer Service’s queue 
Date  = Remission date 
 
Note: When a file has been successfully transmitted, the Iridium Mailer Service deletes 
the file from the queue and proceeds to transmit the next file if any. 
 
.INI file 
 
TsgDataRecorder.ini is a plain-text file that contains configuration information. This file 
is used by SEAS TSG Data Recorder to save information about the application setup, and 
preferences. "INI" stands for initialization (.INI File, More abstraction using text 
between programs, not within programs.doc). The file has to be in the same directory 
where the application runs. 
  
 


