
 
SEAS AutoIMET Data Logger User’s Guide 

 
 

 
Introduction 
 
 
The SEAS AutoIMET (Automatic [Air-Sea] Interaction Meteorology system) Data 
Logger is a real time data acquisition, data processing, data recording, and data 
transmitting application that operates on the Voluntary Observing Ship program (VOS) 
vessels to produce high quality marine weather observations. 
 
As shown in Figure 1, the SEAS AutoIMET Data Logger software connects to the 
Remote Computer System using sockets or serial port to retrieve a comma delimited data 
stream containing the measured weather parameters. The data are transmitted on a user-
determined schedule; typically this is hourly using the meteorological observation BBXX 
format. 
 
The message is placed in the transmit queue. Periodically, the transmit queue is scanned 
and if a suitable file is ready for delivery, a connection is stablish and they will delivered 
to the distribution address. 
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Figure 1 
 
It was developed in the Integrated Development Environment (IDE) from Microsoft 
Visual Studio C++ 2008 Standard Edition under Windows 7. 

 
Contact Information 
 
Caridad Ibis Gonzalez 
Software Developer 
UM/RSMAS/CIMAS and NOAA/AOML/PhOD 
4301 Rickenbacker Causeway 
Miami, FL 33149 
Phone: (305) 361-4322 
Fax: (305) 361-4392 
E-mail: caridad.i.gonzalez@noaa.gov 
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User Interface 
 
The design of the SEAS AutoIMET Data Logger apply some basic principles making the 
design something the user will enjoy working with it every day. 
 

 
 
 
Main screen 
 
Ship information group: 
 

 Company Name is indicating the company’s name. 
 
 Ship Name is indicating the ship’s name. 
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 IMO Number is indicating the ship’s IMO number. 
 

 Call Sign is indicating the ship’s call sign. 
 
 
These fields have to be filling out in the SEAS Console application’s Main menu > 
Setup > Administration. It is mandatory to fill out prior to producing any type of 
weather observations. 
 
AutoIMET data 
 

 Date: Shows formatted date that has been gotten from Remote Computer System. 
 

 Time: Shows formatted time that has been gotten from Remote Computer 
System. 

 
 Latitude: Shows formatted latitude (DD MM) that has been gotten from Remote 

Computer System. 
 

 Longitude: Shows formatted longitude (DDD MM) that has been gotten from 
Remote Computer System. 

 
 Speed over ground: Shows formatted sheep speed that has been gotten from 

Remote Computer System. 
 

 Course over ground: Shows formatted sheep course that has been gotten from 
Remote Computer System. 

 
 Barometric pressure with the correction factored in: Shows a calculated value. 

The barometric pressure is different at different heights.  The barometric pressure 
sensor is up on a pole and the pressure wanted is the pressure at the ship height. 
 

 Barometric height: Shows the barometer height above SSL previously set in 
SEAS Met Observations Logger application Main menu > Setup > Meta data 
> Barometer tab. 
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Used algorithm:  
 

 
 Barometric pressure: Shows formatted barometric pressure that has been gotten 

from Remote Computer System. 
 

 Relative humidity: Shows formatted relative humidity that has been gotten from 
Remote Computer System. 

 
 Air temperature: Shows formatted air temperature that has been gotten from 

Remote Computer System. 
 

 Wet bulb: Shows formatted wet bulb that has been gotten from Remote 
Computer System. 

 
 Dew Point: In this field would show a gotten from Remote Computer System 

value or a calculated value using the recommended WMO formula. The dew point 
temperature is the temperature at which the air can no longer hold all of its water 
vapor, and some of the water vapor must condense into liquid water. At 100% 
relative humidity, the dew point temperature and real temperature are the same. 
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Used algorithm: 
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 Sea temperature: Shows formatted sea temperature that has been gotten from 
Remote Computer System. 

 
 True wind speed: Shows formatted true wind speed that has been gotten from 

Remote Computer System. 
 

 True wind direction: Shows formatted true wind direction that has been gotten 
from Remote Computer System. 
 

 Ship’s heading: Shows formatted ship’s heading that has been gotten from 
Remote Computer System. 

 
 Relative wind direction: Shows formatted relative wind direction that has been 

gotten from Remote Computer System. 
 

 Relative wind speed: Shows formatted relative wind speed that has been gotten 
from Remote Computer System. 

 
Unchecked elements will not be included in the message; the user has to insure that each 
item that is in use is checked. 
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If Dew point is unchecked and Air temperature and Wet bulb are available it will be 
calculated. 
 
The grayed fields that precede each value represent its sequence on the incoming 
message.  
 
When the data is out of bounds, it will be display in red. If the observer sees that the 
element is in red, he/she can toggle off that particular element. 
 
 
Bounds: 

 
Min Value Field Max Value

900  Barometric pressure 1099
30 Relative humidity 100

-40 Air temperature 55
-30 Wet bulb 50
-30 Dew point 50
-6 Seas temperature 40
0 True wind speed 200
0 True wind direction 360
0 Ship’s heading 359
0 Relative wind direction 360
0 Relative wind speed 200

 
VOSClim: Indicates if the vessel participates in VOSClim project or not. 
 
Raw data: Shows every second unformatted comma delimited data stream containing the 
measured weather parameters that has been gotten from Remote Computer System. 
 
Archive: Displays the archive observations process status. 
 
At: Displays the date when the last archive observations process occurred. 
 
Transmission: Displays the transmission observations process status. 
 
At: Displays the date when the last transmission observations process occurred. 
 
Note: US government and international government agencies agreed upon all the data in 
the AutoIMET software.  It should only be changed by agreement of these agencies. 
 
Save button: Saves into the persistent platform the application setup. 
 
Status bar: Provides status information from Remote Computer System communication, 
and application. 
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Main Menu 
 
File > Exit: Exit the application 
 

 
 
 
Use this command to end the AutoIMET Data Logger application. You can also use the 
Close command on the application Control menu. 
 
View > Status Bar: Show or hide the Status Bar. 
 

 
 
 
Use this command to display and hide the status bar, which describes the action to be 
executed by the selected menu item, and keyboard latch state. A checkmark appears next 
to the menu item when the status bar is displayed. 
 
The status bar is displayed at the bottom of the AutoIMET Data Logger window. The left 
area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus. This area similarly shows messages that describe the 
application’s status. 
 
The right areas of the status bar indicate which of the following keys are latched down: 
 
Indicator Description 
CAP  The Caps Lock key is latched down. 
NUM  The Num Lock key is latched down. 
SCRL  The Scroll Lock key is latched down. 
DATE  The system clock. 
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Setup > Data source…: Manages the data source's settings. 
 

 
 
 
Once selected the windows Data source appears. 
 

 
 
 
The user can select to connect SEAS AutoIMET Data Logger software to the Remote 
Computer System using socket or serial port to retrieve a comma delimited data stream 
containing the measured weather parameters. 
 
If the selection is Serial port (RS232) set up the serial port communication then click 
OK. The SEAS AutoIMET Data Logger will be fed through the serial port. The sent lines 
of data have to start with "$", and terminate in a semi-colon. 
 
If the selection is Socket type the IP address of the computer where the Remote 
Computer System is running, and insert the port number designated for your particular 
ship; each ship will have its own unique port number, it may be the same but it will 
probably be different. Click OK. The SEAS AutoIMET Data Logger will connect with 
this remote computer via socket. 
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Setup > Message format settings…: Sets the Remote Computer System message 
format. 
 

 
 
 
Once selected the window RCS Message format appears and the user can establish the 
measured value sequence in the incoming Remote Computer System’s message. Also the 
user can set the possible delimiters. 
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Setup > Meta data…: Displays the meta-data’s settings. 
 

 
 
 
Once selected the window Meta data appears. 
 

 
 
 

 Thermometer height is indicating the height of the thermometer sensor above 
sea level. 

 
 Anemometer height is indicating the height of the anemometer sensor above sea 

level. 
 

 Barometer height is indicating the height of the barometer sensor above sea 
level. 

 
 Seas surface temperature depth is indicating the height of the particular sensor 

above sea level. 
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 Sea surface temperature type is indicating how determine the sea surface 
temperature, i.e., “intake measured”, “hull contact”, “bucket measured” or 
“neither intake, bucket or hull”. 

 
 Wet bulb temperature method is indicating whether the wet bulb is “measured” 

or “computed”. 
 

 Anemometer method is indicating whether the wind is “measured” or 
“estimated”. 

 
 Maximum height of deck cargo above maximum load line is used as metadata 

when ships are participating in VOSClim project.  It is not transmitted but 
collected and archived. 

 
 Departure of summer maximum load line from actual sea level Consider the 

difference positive when the Summer maximum load line is above the level of the 
sea and negative if below the water line. It is used as metadata when ships are 
participating in VOSClim project.  It is not transmitted but collected and archived. 

 
 Observation platform is indicating the platform where the observation is done. 

 
 Country which has recruited the ship 

 
All these values are managed in Met Observations Logger application Main menu > 
Setup > Meta data. Click Refresh to see the current setting. 
 
Setup > Archive and transmission: Manages the archive and transmission’s settings. 
 

 
 
 
Once selected the window Archive and transmission setup appears. 
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 Archive observation data?: Determines either the user want to archive the 
acquired data or not.  

 
 Transmit observation data?: Determines either the user want to transmit the 

acquired data or not. 
 

 Frequency:  Determines the transmission schedule. 
 

Synoptic hours (6 hours): Observations taken at 6-hourly interval, at 00:00, 
06:00, 12:00, 18:00 UTC. These are also known as the main synoptic times. 
 
3 hours: Observations taken at 3-hourly interval, at 00:00, 03:00, 06:00, 09:00, 
12:00, 15:00, 18:00, 21:00 UTC. 
 
2 hours: Observations taken at 2-hourly interval, at 00:00, 02:00, 04:00, 06:00, 
08:00, 10:00, 12:00, 14:00, 16:00, 18:00, 20:00, 22:00 UTC. 
 
1 hour: Observations taken at 1-hourly interval at the top of the hour. 
 
30 minutes: Observations every 30 minutes. So at 0 minutes and 30 minutes 
passed the top of the hour. 
 
15 minutes: Observations taken at 0 minutes, 15 minutes, 30 minutes, 45 minutes 
passed the top of the hour. 
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Setup > Transmission queue directory: Select the transmission queue path. 
 

 
 
 
Use this command to select the transmission queue directory, where SEAS AutoIMET 
Data Logger will post the files ready to transmit. A Browser for Folder dialog appears 
that allows the user to select a folder. 
 

  
 
 
When this dialog box comes up, it displays the Desktop folder as the parent and all the 
other folders can be located from it. To use it, the user can click one of the folders or 
drives and click OK. If the desired folder is not seen but is available, the user can expand 
the existing folders and drives, click the desired folder, and click OK. If the necessary 
folder is not available at all, the user should first create the desired folder outside the 
application. 
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RCS > Connect socket: Connects the Remote Computer System socket. 
 

 
 
 
RCS > Disconnect socket: Disconnects the Remote Computer System socket. 
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Tools > Files location: Displays the application files path where SEAS AutoIMET Data 
Logger’s files can be found. 
 

 
 
 
Once selected the window Files location will appear: 
 

 
 
 
Tools > Show ships synoptic code FM13-X: Shows the observation message in BBXX 
format. Instantaneous data (that is received closest to the display time) is displayed. 
 

 
 
 
Once selected the window Weather Observation – Synoptic Code appears. 
 



SEAS AutoIMET Data Logger User’s Guide 
________________________________________________________________________ 

NOAA/AOML Page 18 of 23 3/7/2016 

 
 
 
Tools > Transmit and archive observation: Forces transmissions placing in the SMTP 
transmit queue the observation message in BBXX format. Instantaneous data (that is 
received closest to the transmit time) is transmitted. 
 

 
 
 
Help > Help Topics: Displays the opening screen of help. From the opening screen, you 
can jump to step-by-step instructions for using AutoIMET Data Logger and various types 
of reference information. 
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Help Help > About SEAS AutoIMET Data Logger…: Use this command to displays 
the copyright notice and version number of your copy of AutoIMET Data Logger. 
 

 
 
 
Once selected the window About SEAS AutoIMET Data Logger appears. 
 

 
 
 
Info: This menu provides you links to documents that can help you work with Met 
Observations Logger.  
 

 
 
 
It contain following documents: 
 

 SEAS AutoIMET Data Logger User’s Guide. 
 How to install and setup the SMTP mailer service. 
 Starting SCS. 
 National Weather Service Observing Handbook1. 
 VOSClim brochure. 
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Ships synoptic code FM13-X 
 
The ships synoptic code FM-13-X-SHIP is the form of the message as distributed on the 
Global Telecommunications System (GTS), and is the standard set forth by the World 
Meteorological Organization. This code is comprised of 23 groups of symbolic letters 
representing meteorological and oceanographic elements, report identification and ship 
location data. The code has three main sections - 0, 1, and 2. 
 

  
 
 
Section 0, consisting of the first 5 code groups, contains the identification data (ship 
report identifier, ship’s call sign, date, time, location), and units of wind speed used. 
 

 
 
 
Section 1 consists of code groups 6-14 and contains most of the meteorological data of 
the report (precipitation and weather data indicators, cloud base height, visibility, cloud 
cover, wind direction and speed, air and dew point temperatures, sea level pressure, 
tendency, and amount of change, present and past weather, and cloud type). 
 

 
 
 
Section 2 consists of code groups 15-23 and contains ships movement data (ships course 
and speed), oceanographic data (sea surface temperature, sea period and height, primary 
and secondary swell direction, period, and height), and ice data (for any ice accreting on 
ship or on the sea surface), and the wet bulb temperature group. 
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More information can be finding into the National Weather serving Observing 
Handbook1  
 
Any elements not reported or out of bound are normally coded with a slash (/) to 
indicated missing data. 
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In the first five groups, this is the Synoptic Code Section 0, all values are mandatory, if 
any error occurs or any data is missing, the entire report will be discarded. 
 

Archiving data 
 
The SEAS AutoIMET Data Logger collects marine weather data from Remote Computer 
System about once every 1 minute; the data is transmitted using the meteorological 
observation BBXX format on a user-determined schedule, typically this is hourly or 
when the user hit the Main Menu > Tools > Transmit and archive observation 
command. Instantaneous data (that is received closest to the transmit time) is transmitted. 
 
The application archives the collected data in IMMT.txt file into the archive directory 
C:\Users\Public\Public Documents\AMVERSEAS_V9\Archive\ArchiveMet. 
 
The IMMT.txt file is a recording of all observations taken on the vessel in International 
Maritime Meteorological Tape (IMMT) version IMMT-5 format.  .  Port Meteorological 
Officers (PMO) should retrieve the archived file when they meet the ship and send the 
data to the National Climatic Data Center (NCDC). 
 
The supported Minimum Quality Control Standards (MQCS) version is the Version 7. 
 

Data transmission 
 
It is very important that observations be transmitted quickly. This ensures that the report 
will arrive in time for use by the marine forecaster. The name of the binary formatted file 
is CallSign_YYYYMMDDHHMMSS_AI_MET.bin. This file has a "bin" extension but 
it is really a “txt” file. It is a SMTP's requirement. 
 

 
 
 
The messages will be transmitted automatically also it can be transmitted from the main 
menu by selecting Tool > Transmit and archive observations command. The 
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transmission process in SEAS AutoIMET Data Logger application is a pseudo 
transmission process. It consists to post the generated 
CallSign_YYYYMMDDHHMMSS_AI_MET.bin file into the Iridium’s queue located in 
the user-selected directory for the real transmission via satellite using the Iridium Mailer 
Service. 
 
.INI files 
 
The .ini files are plain-text files that contain configuration information. "INI" stands for 

initialization. The files will be created during the installation process and never 
should be manually changed. 
 

 AutoImetDataLogger.ini is used to save information about the application setup, 
and preferences. 

 
Directory structure 
 
Archive directory 
 
 C:\Users\Public\Public Documents\AMVERSEAS_V9\Archive\ArchiveMet. 

 


