SEAS Console Version User’s Guide

Introduction

The SEAS Console is the interface to managing the SEAS programs' activities. In simple
terms, it is a utility, where all the SEAS applications management functions are found.

SEAS Console provides several key benefits:

e Task orientation: The tools being used to work with SEAS Console are
application oriented.

e Integration: The user interface for the management of all tasks is held in a single
console.

e Extensibility: Developers can ease extend the base functionality of SEAS
Console. This allows reuse the tools without writing a lot of code.

e Debugging: Creating log file of anomalies for further debugging.

It was developed in the Integrated Development Environment (IDE) from Microsoft
Visual Studio C++ 2008 Standard Edition under Windows 7.
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User Interface

w# SEAS Cansale [

File View 5Setup Reports Utilities Help Info

e Task Status
;w‘.} .SEAS Transceiver Interface Stop
V« [l 5245 ¥BT Data Recorder Stop
I | BseAs TSG Data Recorder Stop
AL Bl 5545 Po-watchdog Stop

.SEAS Met Observations Logger Stop
.SEAS AutoIMET Data Logger Stop
B amver Reporter Stop
.Remnte Command System Stop

Please Wait... Loading -

Ready

The SEAS Console is separated into these sections:

e Menu bar: Use the menu items to insert applications, configure properties, and
access additional information.

e File: Exits the application.
e View: Shows or hide the Status bar.
e Setup: Setups SEAS Console application.

e Reports: Generates reports such the marine mammals sightings to National
Marine Mammal Laboratory.

e Utilities: Provides user support.

e Help: Views the About dialog box for copyright information and which
versions of the product are installed.

e Info: Links to documents.
e Task list: Displays the tasks to managing as well as the status.

e Status bar: Displays the status of the current activity.

NOAA/AOML Page 2 of 14 3/7/2016



SEAS Console User’s Guide

Main Menu

File > Maximize: This command is always disabled see system tray to know how to
maximize the SEAS Console application window.

®¥ SEAS Console

Yiew Setup Reports  Ltlities Help  Info

Task. Skatus
.SEF'.S Transceiver Inkerface Stop
Bl =45 ¥ET Data Recorder Stop

Mirirnize

Exit

File > Minimize: Use this command to minimize the SEAS Console application window.
An icon will be display in the system tray.

M SEAS Console
&M Yiew Setup Reports  Ukilities Help Info

L
Mirirnize: Task Status
.SEF'.S Transceiver Inkerface Stop
Bl =45 #6T Data Recorder Stop

The notification area -commonly
referred as the system tray for Microsoft- 5 - ” —

. . ) E = :' =

is the portion of the taskbar usually at IEE Pt BRAO AT

the bottom right corner that displays icons for easy access to system functions such as
printer, modem, sound volume, battery status, and more. It is used to launch and monitor
running applications.

SEAS Console: Right click Far menu

A single right click on the tray icon About SEAS Console
will bring up a menu while a double
click will perform the default action
(Minimize or Maximize SEAS
Console application window). Help

Minimize

Exit

The About SEAS Console option
will display a window with the version information.
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About SEAS Console [

s SEAS Console, Version 3.3.1
U Copyright (C) 2015

Atlantic Oceanographic and Meteorological Labaratory
{ADML), USA

Version build date: Mar 7 2016 17:03:13

File > Exit: Exits the application

*" SEAS Console
&= iew Setup  Reporks  Ukilities Help  Info

Minimize Task Skakus
Exit .SEF'.S Transceiver Interface Stop
ik
| Bl =t45 #6T Data Recorder Stop

Use this command to end the SEAS Console application. You can also use the Close
command on the application Control menu.

Since the SEAS Console needs to stay running all the time unless they are explicitly
terminated it prompts the user for a password to exit the application.

Password nedded to exit

»
H Passwiord; | |
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View > Status Bar: Shows or hides the Status Bar.

®¥ SEAS Console

W=D Setup Reports  Ltlities Help  Info

v Sktakus Bar
I_ —n—r:rcL Skaknz |

Use this command to display and hide the status bar, which describes the action to be
executed by the selected menu item, and keyboard latch state. A checkmark appears next
to the menu item when the status bar is displayed.

The status bar is displayed at the bottom of the SEAS Console window. The left area of
the status bar describes actions of menu items as you use the arrow keys to navigate
through menus. This area similarly shows messages that describe the application’s status.
The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description

CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.
DATE The system clock.

Setup > Administration: Manages the SEAS administration information.

w# SEAS Cansale = 23 |

File View |Setup | Reports Utilities Help Info

Administration...

Automatic startup...

Outgoing server (SMTP) settings...

Bl 545 Pe-watchdog Stop

A\‘_:v:l -HI—IHII T

Use this command to insert the necessary information for SEAS application’s operation.
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Fr |
Administration I&

Cruise
Cruise Line  ax 10 Start - g15/2014 Transect 77
Date 15/ T Number
Cruise
e POS7552 EndDate  5/19/2014 +
Ship
Company Call Ssian®™  wpek
o . .
E]E'r'.jqe" Horizon Mavigator Has IMO number?
Maxirnum 77.5 MO 7116315 Mandatory
Speed® Mumber=
Medical staff* Forward INMARSAT
MNumber
[ Murse [ mMD []amver [ | MAREP
Equipment type
[ ra Mone []1asREP
Ship rider
Name Ibis Gonzalez
E-mail caridad.i.gonzalez @noaa.gov
Phone (305) 361 4322

Cruise group:

e Cruise Line is indicating the line number (e.g. AX10, AX08).

Start Date is indicating the start cruise’s date.

End Date is indicating the end cruise’s date.

Cruise Name is used by SCRIPPS.

Transect number is a consecutive number indicating transect.

Ship group:
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e Company Name is indicating the company’s name.

e Ship Name is indicating the ship’s name.

e Call Sign is indicating the ship’s call sign.

e Has IMO number? check box indicates if the ship has IMO number or not. If it
is checked the IMO Number field is mandatory. If not, is the opposite. It is useful
for smaller vessels that do not have an IMO Number

e IMO Number is indicating the ship’s IMO number.

e Maximum speed is indicating the ship’s maximum speed.

Medical staff group: Used to report the medical capability aboard the vessel during the
voyage. It is important to accurately report your vessel’s medical resources EVERY
VOYAGE.

e None if no medically trained personnel are aboard.

e Nurse if a trained nurse is aboard.

e PA if a physician’s assistant or paramedic is aboard.

e MD if a medical doctor or physician is aboard.

e Forward group: Used to request relay of the AMVER report to certain other ship
reporting systems.

INMARSAT group: Used to provide information on the best way to contact the vessel
quickly.

Ship rider group:
e Name is indicating the technician’s name.
e Email is indicating the technician’s email address.
e Phone is indicating the technician’s phone number.

When this dialog box comes up, it displays the information previously saved. To use it,
the user can edit the fields and click OK.
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Setup > Automatic startup: Defines which application has to be started automatically.

~

e SEAS Console

2]’

File View [Setup | Reports Utilities Help Info

Administration...

Automatic startup...

Outgoing server (SMTP] settings...

Bl seas Pc-watchdog
]

Stop

Once the Automatic startup window appears select/unselect the applications that SEAS
Console has to startup automatically. Also the user cans choice if the SEAS Console
window will be minimized or not after it starts.

P

Automatic startup

AMVERSEAS applications

SEAS Transceiver Interface

[] SEAS ¥ET Data Recorder

[| sEAS TSG Data Recorder

[] sEAS PC-Watchdog

|:| SEAS Met Ohservations Logager
[]sEAS AutoIMET Data Logger
[] AMVER Reporter

Remote Command System

[ Minimize SEAS Console window
on startup

QK ] [ Cancel

=)
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Setup > Outgoing server (SMTP) settings: Configures the outgoing server (SMTP).

-

w SEAS Console

28]

File View [Setup | Reports Utilities Help Info

Administration...

Automatic startup...

Outgoing server (SMTP] settings...

Bl se2s Pc-watchdog Stop

Once the SMTP Server window appears you are able to input the outgoing server

settings.

The SMTP (short for Simple Mail Transfer Protocol) works like a post assistant, handling
the sending of emails from an email client to an email server. It receives outgoing mail
messages from users and routes them to the mail recipients they are intended for.

SMTP Server [‘$_<|

Sekkings

=mkp. grnail. com

SErver name:

Port: S57

Buthenticakion

User name: | caridad.i.gonzalez@noaa.goy
Passwiord; | kbbb sk ok

Conneckion

[ Connected to the internet through a dial-up connection?

Mamne:! Tridium ﬂ
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Reports > Buoy deployment logger: Reports buoy deployment.

r .
w# SEAS Console -2

File View Setup [Reports| Utilities Help Info

Buoy deployment logger...

T .
. Marine mammal report...

Mg,

)
In A

Use this command to report drifter or Argo buoy deployment. The collected information
has to be send to the Global Drifter Center.

Reports > Marine mammal report: Reports sightings of marine mammals.

- .
w# SEAS Console e S|

File View Setup [Reports| Utilities Help Info

Buoy deployment logger...

Ta .
Marine marmmal report...

Use this command to report sightings of marine mammals to National Marine Mammal
Laboratory.

Utilities > Date and Time: Sets date, time, and time zone for SEAS computer.

*¥ SEAS Console

File Miew Setup Reports BEWIEEES Help  Info

Dakte and Time. ..
Task Display mapped profiles, ., 5 |

[ P e S e [ e

e
-
L oo -

Use this command to change the computer's date and time. This will open the Date/Time
Properties window.
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7= Date and Time &J

—

Date and Time | Additional Clocks

Date:
Friday, August 22, 2014

Time:
11:11:52 PM

[ I@]Char‘lgv& date and time...

Time zone

(UTC) Casablanca

[ Change time zone... ]

Daylight 5aving Time ends on Sunday, October 26, 2014 at 3:00 AM. The
clock is set to go back 1 hour at that time.

[¥] Motify me when the clock changes

Get mere time zene infermatien enline
How do I set the clock and time zone?

0K ] [ Cancel Apply

In this window you can adjust the time, date, and time zone. To change the time zone,
click the Change time zone button.

For proper operation of AMVERSEAS, the computer time and time zone must be set
correctly to (GMT) Coordinated Universal Time. Once the computer time zone is set
correctly, it should not be changed. If the time zone changes the (GMT) Coordinated
Universal Time is not affected, so do not do anything.

Once the proper date and time has been set, click OK.

Note: Do Not ! select Grennwich Mean Time: Dublin ... because it uses daylight
savings time which causes AMVERSEAS all sorts of problems.

Utilities > Display mapped profiles: Displays selected profiles locating them on a world
map. Also it converts file from .bin to .ndc format.

M SEAS Console

File ‘iew Setup Reports BERINEES Help  Info

Date and Time. ..

Task. Display mapped profiles. .. 5 ‘

e T CFam

e
"
L] oo o W
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Once selected this command the dialog Profile Map appears.

#T+ SEAS 2000 - Profile Map

0
02-26-2004 05:33 GMT
034.593 5
014312 E

Then select File > Open. This will open up all dropped profiles into a world map. Track
lines from the XBT drops can be viewed. Drops can also be viewed individually. If File >
Convert to NODC is selected then all files will be converted to the NODC (*.ndc)
formatted file.

Help > Help Topics: Displays the opening screen of help. From the opening screen, you
can jump to step-by-step instructions for using SEAS Console and various types of
reference information (under construction).

*¥ SEAS Console
File Wiew Setup Reports  Ukilities NeEES Info

Help Topics

i, Task : |
- % About SEAS Consale, ..
f_@i& ISEF'.S Transceive
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Help > About SEAS Console...: Use this command to displays the copyright notice and
version number of your copy of SEAS Console.

M SEAS Console
File Wiew Setup Reports Utilities BEEM Info

Task ; I
about SEAS Consale. .
-SEF'.S Transceive ABOUE SEAS Console

Once the command is selected the About SEAS Console dialog box appears.

About SEAS Console [

s SEAS Console, Version 3.3.1
U Copyright (C) 2015

Atlantic Oceanographic and Meteorological Labaratory
{ADML), USA

Version build date: Mar 7 2016 17:03:13

Info: This menu provides you links to documents that can help you work with SEAS
Console application.

*¥ SEAS Console
File Wiew Setup Reports Ukilities Help RiliE

SEAS Console User's Guide (pdF) I_l
I Il Tack =FAFTTS

It contains following documents:
e SEAS Console User’s Guide.
Task list

The task list displays the tasks to managing as well as their status.
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-

e SEAS Consale

S

File View Setup Reports Utilities Help Info

Task

.SEAS Transceiver Interface

Status

Running

Stop

Stop

o Stop

.SEAS AutoIMET Data Logger Stop

Bl 2MmvER Reporter Stop
.Remote Command System Running

Please visit our website at AMVERSEAS

Ready
Uninstalled The application was not installed. Yellow
Stop The application was installed but it is not running. Red
Running The application was installed and it is running. Green

You can start an active (previously installed during the installation process.) application
selecting an application on the task list, and right click. Then a popup menu appears, and
you can click Start.
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